Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!


Please consider registering

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —

— Match —

— Forum Options —

Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
easy fix for tx glitches
Tags: Syma X9
March 15, 2014 - 11:16 am

ill have to figure out how to post a pic..but 11 flights with this mod, and my throttle issue is gone! I realized the throttle lever hit at the bottom of the tx slot, so I knew I would have to grind it down some. I wasnt sure if I would need to modify the stop on the inside. I diassembled the tx, and dremeled out the bottom of the throttle slot about 1/4" , and it worked! It occured to me the cases on these txs limit control travel. (basically I just allowed the throttle to go below the pot contact point) I might try some flights with the "face" off of my Apache tx to see what happens. helicopter 

March 5, 2014 - 3:27 pm

I spoke too soon, the throttle is acting up again. Im going to grind the stop to move the throttle below the lowest setting on the pot, I'll try to post some pics..may be a few days

March 3, 2014 - 9:39 am

We think alike..I was going to break out the dremel and grind down the throttle stop if the cleaner didnt work!

March 3, 2014 - 4:34 am

Sounds good to me--they'll do that occasionally. I think one of my remotes (I want to say my first one, which I don't have in front of me) I carved a slight bit of the plastic below the stick out of there with a pocketknife to get it to go the rest of the way down, but that's because I had already screwed up the remote and had to push down on that stick to get a good connection)

March 2, 2014 - 1:37 pm

After a few weeks of fllying, around 30 flights, my S-108 Cobra started acting up. As soon as the chopper would bind to the tx, the blades would start up even with the throttle in full off position. I could tell it was in the throttle. I decided to start simple, and try cleaning the throttle potentiometer with CRC  QD electronic cleaner...I disassembled the tx, and gave it a good shot. I also shot the directional control as well. Im happy to report that this fix worked great! the controls actually seem a bit more responsive..that could be my imagination..but I do know it fixed my throttle issue!

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
13 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

justdon: 9

nope: 5

groggy: 2

stewartcristan: 1

Member Stats:

Guest Posters: 729

Members: 1150

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 16

Topics: 1276

Posts: 8191

Newest Members:

Zeettaudib, Jeffreywap, samuel827, RobertTam, Laxmi123, RobertRip

Administrators: Syma Freak: 1442, JamDJ: 260