Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
S800G Drift
My new S800G won't fly staight.
Tags: Syma X9
Avatar
Iroc3
Member
Members
March 16, 2013 - 11:47 pm
Member Since: March 16, 2013
Forum Posts: 3
sp_UserOfflineSmall Offline

My new S800G won't fly staight.   When I fly in a forward direction it seems to also be drifting to the right.   I have had an S107G for awhile and I love it.   I'm new to the S800G.   Does any one have th same issues?   Thanks in advance for any feedback.

Avatar
Syma Freak
Admin
March 17, 2013 - 2:52 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Silly question but have you trimmed via remote,also any bad crash or did it drift straight out of the box?

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
Iroc3
Member
Members
March 18, 2013 - 7:08 am
Member Since: March 16, 2013
Forum Posts: 3
sp_UserOfflineSmall Offline

I have trimmed via remote but I was wrong in my first statement.   It does drifrt but it difts to the left while in a forward motion.   I did crash within the first few seconds of flying so I'm not really sure if it did this right out of the box or not.   The drift is not like it's turning left.   It feels as though it is alieron left.   I can adjust with right alieron but it really slows down my forward motion.   I was expecting a faster forward motion with the S800G.   It seems slower than  my S107G.

Avatar
Iroc3
Member
Members
March 24, 2013 - 2:12 am
Member Since: March 16, 2013
Forum Posts: 3
sp_UserOfflineSmall Offline

I must have broken it somehow or maybe the remote is bad.   I've rebuilt my S107G from the ground up a few times.   I would atempt a repair on the S800G if I knew where to start.   Does anyone know of any videos posted online demonstrating repairs on the S800G.   I will keep looking and will let you know what I find.

Avatar
Syma Freak
Admin
March 30, 2013 - 2:50 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Iroc3 said
I must have broken it somehow or maybe the remote is bad.   I've rebuilt my S107G from the ground up a few times.   I would atempt a repair on the S800G if I knew where to start.   Does anyone know of any videos posted online demonstrating repairs on the S800G.   I will keep looking and will let you know what I find.

Found this video below- will get one to Supernova to do a few videos on repairs...

http://youtu.be/nW_6s56LyUs

 

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
CPD
PA
Member
March 31, 2013 - 12:58 pm
Member Since: November 18, 2011
Forum Posts: 1093
sp_UserOfflineSmall Offline

Might be a messed up swash plate. I don't know how to check and fix it on these yet, but I'll learn sure enough when one of mine gets its plate knocked out of whack. That's a very common problem on 4ch helis from everything I've heard.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Old_Iron_Spine: 308

bvc: 250

Redfive: 221

Freeonthree: 214

MikeK: 172

drewdane: 155

Member Stats:

Guest Posters: 2

Members: 1650

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1262

Posts: 8128

Newest Members:

samanthabaker1202, Projectdiy, ter, gzdenek, cyclib, ron hallam

Administrators: Syma Freak: 1459, Supernova: 771, JamDJ: 258