Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
X5C-1 Signal Issues...
Signal issues with the X5C-1 - Losing control around 45 feet.
Tags: Syma X9
Avatar
darth_chad
Guest
Guests
January 22, 2015 - 11:00 am

My father and I just purchased (2) X5C-1 quadcopters to play with.  We love it!  However, I have an issue.  My father's quad has started losing signal around 45 feet.  My quad still does well with controlling over long distances.  I tried using my controller for his quad and it still loses signal.  What it does is it takes off under control, but then when it gets to a certain distance, the lights at the bottom blink and you lose control of the quad.  Sometimes you can get the control back as it is either flying or falling to the ground.  Is there are any fix to it?  When we first got the quads about a month ago, his wasn't doing this.  Did something come loose or is this a common issue?  Any feedback would be great!  Thanks.

Avatar
CPD
Guest
Guests
February 6, 2015 - 1:08 pm

Well, the first thing to check is the batteries in the remote. They might have aged a bit if you used it a lot over that month. I'm not really an expert with the quads, I just have a baby X3 that's just enough to keep me in the hobby when I get a chance here and there. Thus, hopefully SF or somebody with more quad experience can come along and help.

Avatar
MikeK
Member
Members
May 23, 2015 - 1:50 pm
Member Since: February 1, 2014
Forum Posts: 178
sp_UserOfflineSmall Offline

Darth Chad,

It's been awhile since CPD suggested a (likely) cause of the signal problem with your dad's x5.  I'm sure I'm not the only one who is curious to know if controller batteries were indeed the problem and, if not, have you determined what is?  

Don't leave us in the dark.  What have you found?

Avatar
Syma Freak
Admin
June 8, 2015 - 10:09 am
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

I have two X5C Quads and have not had any problems really losing signals until i just pushed it to far away, below a video on Youtube that shows a mod. Have you tried binding your Dad,s X5C with your remote to see if it might be remote problem, pretty sure should bind ok.

Sorry just saw on earlier post you have tried that correct?

"Fly like a butterfly sting like a Syma" http://syma107.com

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Redfive: 219

MikeK: 178

Gyrobob: 35

SymaGuru: 32

RobertNH: 15

Airsucker: 13

Member Stats:

Guest Posters: 710

Members: 494

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1269

Posts: 8165

Newest Members:

nataliemn16, rebeccayj3, lolatl4, marian8gaw, Nnerjstaln49m, mitzius18

Administrators: Syma Freak: 1429, Supernova: 733, JamDJ: 254