Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Right out of the box
Get your act together
Tags: Syma X9
Avatar
lew803
Guest
Guests
January 30, 2013 - 10:17 am

Opened a new quad .Right out of the box and guess what ,it will not bind in the traditional manner.The method:turn on the tx,plug in battery,place on level surface,pick up tx,they bind in seconds.This did not work.I had to plug in battery,set on level surface ,turn on tx,pick up tx and then it would bind.After that it would bind in the traditional manner each time I used it.Doesn't happen often.Usually come already to bind:Tx,battery,level surface, bind.Just saying........ 

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
7 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

groggy: 2

cyclib: 2

Shwan: 1

Member Stats:

Guest Posters: 722

Members: 802

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

Rodneygot, ritanota, petr-osipovbm, wapedged, BillyBoabe, gbalychik

Administrators: Syma Freak: 1432, JamDJ: 255