Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
S107g Lift problem
Just started having lift problems with s107g
Tags: Syma X9
Avatar
snakeshaw
Guest
Guests
June 27, 2014 - 5:48 pm

Hi everyone, My name is Sam I live in Montana USA and Love my S107g.  I have flown countless times.  I am now having lift issues.  I did the battery Upgrade tonight and had the same result slow little or no lift.  What else could be wrong.  Sorry if this is a silly question.  I couldn't find any topic on this issue. The battery was a 3.7 volt 240 mah battery I bought off amazon.  It is not the original battery.

Avatar
Syma Freak
Admin
June 28, 2014 - 4:53 pm
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

hey_mate-4138Hi Sam,

it sounds like the motors don't have the power to lift, have you checked battery holding the charge, also are the gears all meshing ok and not slipping?

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
Bobtsg
Guest
Guests
February 7, 2016 - 1:34 am

I had the same problem and for me correcting it was getting a new usb charge cable and that resolved it. 

The following users say thank you to Bobtsg for this useful post:

Syma Freak
Avatar
RobertNH
Guest
Guests
February 15, 2016 - 8:08 am

I'm concerned of the battery weight..

I just did the Mod with 200mah batteries and was concerned of the weight. It worked so I'm very happy with it.

If the rotors are spinning to high heaven and you have no lift..  Weight.

Can't believe there's much difference in the lift capability between your 107 and my 108.. Then again, I'm new here and learning from these folks!

 

If the rotors are not spinning to 'high heaven', then I think it's your battery power.

Remember, voltage does not mean wattage is correct. Volts x amperage equals wattage.

3.7 volts does not mean 250mah has been obtained.

Are you charging through your Heli? Then, realize it's set for 150mah (factory battery).

Most charges work on voltage only, reason 'I'm' looking for a real good 'Programmable' charger.

 

Hope this helps..

The following users say thank you to RobertNH for this useful post:

Syma Freak
Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

Airsucker: 13

swordfish010: 8

nope: 5

cyclib: 2

Member Stats:

Guest Posters: 714

Members: 650

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1269

Posts: 8165

Newest Members:

Frgeti44, Adelacix, AnnieVoW, lilianany60, SantoCeamb, annmariebq18

Administrators: Syma Freak: 1429, JamDJ: 254