Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
S107g Lift problem
Just started having lift problems with s107g
Tags: Syma X9
Avatar
snakeshaw
New Member
Members
June 27, 2014 - 5:48 pm
Member Since: June 27, 2014
Forum Posts: 1
sp_UserOfflineSmall Offline

Hi everyone, My name is Sam I live in Montana USA and Love my S107g.  I have flown countless times.  I am now having lift issues.  I did the battery Upgrade tonight and had the same result slow little or no lift.  What else could be wrong.  Sorry if this is a silly question.  I couldn't find any topic on this issue. The battery was a 3.7 volt 240 mah battery I bought off amazon.  It is not the original battery.

Avatar
Syma Freak
Admin
June 28, 2014 - 4:53 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

hey_mate-4138Hi Sam,

it sounds like the motors don't have the power to lift, have you checked battery holding the charge, also are the gears all meshing ok and not slipping?

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
Bobtsg
New Member
Members
February 7, 2016 - 1:34 am
Member Since: February 4, 2016
Forum Posts: 1
sp_UserOfflineSmall Offline

I had the same problem and for me correcting it was getting a new usb charge cable and that resolved it. 

The following users say thank you to Bobtsg for this useful post:

Syma Freak
Avatar
RobertNH
Member
Members
February 15, 2016 - 8:08 am
Member Since: February 15, 2016
Forum Posts: 15
sp_UserOfflineSmall Offline

I'm concerned of the battery weight..

I just did the Mod with 200mah batteries and was concerned of the weight. It worked so I'm very happy with it.

If the rotors are spinning to high heaven and you have no lift..  Weight.

Can't believe there's much difference in the lift capability between your 107 and my 108.. Then again, I'm new here and learning from these folks!

 

If the rotors are not spinning to 'high heaven', then I think it's your battery power.

Remember, voltage does not mean wattage is correct. Volts x amperage equals wattage.

3.7 volts does not mean 250mah has been obtained.

Are you charging through your Heli? Then, realize it's set for 150mah (factory battery).

Most charges work on voltage only, reason 'I'm' looking for a real good 'Programmable' charger.

 

Hope this helps..

The following users say thank you to RobertNH for this useful post:

Syma Freak
Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Old_Iron_Spine: 308

bvc: 250

Redfive: 221

Freeonthree: 214

MikeK: 172

drewdane: 155

Member Stats:

Guest Posters: 2

Members: 1650

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1262

Posts: 8128

Newest Members:

samanthabaker1202, Projectdiy, ter, gzdenek, cyclib, ron hallam

Administrators: Syma Freak: 1459, Supernova: 771, JamDJ: 258