Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
NEW WITH PROBS
Tags: Syma X9
Avatar
letsroll
Guest
Guests
January 19, 2012 - 10:31 am

HI all. bought a 107 for a christmas present for Myself. I have only flown or should I say CRASHED it about 10 times max. Today the gears started to make noise ,and a no lift occured. After closer inspection ,the gears are not stripped but the bottom gear won't engage both small gears at the same time. I pushed in all the pins holding the gears in and pushed the motors down and still no go will not turn both sets of rotor blades at the same time . The bottom gear will not move up or down ,so I am stumped on the fix can anyone help please?

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
6 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

cyclib: 2

groggy: 2

Shwan: 1

Member Stats:

Guest Posters: 726

Members: 913

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

NadejdaJogue, Toranja, JulianDreab, Januszek45Swido, Jamaalcag, nikagreimOnge

Administrators: Syma Freak: 1432, JamDJ: 255