Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
s301g
Avatar
godzilla74
Member
Members
August 8, 2012 - 2:12 am
Member Since: August 8, 2012
Forum Posts: 3
sp_UserOfflineSmall Offline

help  i got a s301g. got ready fly and nothing. the power cut off and on. then no power at all. HELP!!!!!

Avatar
Syma Freak
Admin
August 8, 2012 - 5:32 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

I presume you have charged the 301G and new batteries in remote? Try reposition aerial tied around landing gear to hang down a bit,also make sure the connection on the heli is pushed tight into the two battery connections.....

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
godzilla74
Member
Members
August 14, 2012 - 1:48 am
Member Since: August 8, 2012
Forum Posts: 3
sp_UserOfflineSmall Offline

no luck try all of that no go. check the battery,motors,voltage to the battery. could it be the radio. any help would be good at this time. thank you for your time. help

Avatar
Syma Freak
Admin
August 14, 2012 - 4:14 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Hang on Godzillia74.. Do not go belly up here.Have you contacted Raptor yet or CPD,these guys over take me on electronics,we will get to your problem.. will get back to you with some ideas..SF

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
Raptor
Cheshire, England
Member
August 14, 2012 - 9:10 pm
Member Since: April 24, 2012
Forum Posts: 141
sp_UserOfflineSmall Offline

I don't currently have one of these helicopters, so i will try and guide you through with a general checklist.

 

Make sure your battery's are fully charged on both the transmitter and helicopter. (if you aren't sure, put the li-po back on charge, and replace the battery in the transmitter)

extend the aerial on the transmitter and helicopter fully.

make sure that you have set the switch on the helicopter & transmitter to ON/I

check that the lights come on, on both the helicopter and transmitter.

 

Make sure that you have checked the above points, If you are still experiencing problems with it, i will try and guide you through finding the problem.

No trees were harmed in the sending of this message; however, a significant number of electrons were slightly inconvenienced.

Avatar
Syma Freak
Admin
August 14, 2012 - 9:16 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Good points Raptor!!

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
godzilla74
Member
Members
August 14, 2012 - 11:39 pm
Member Since: August 8, 2012
Forum Posts: 3
sp_UserOfflineSmall Offline

i have done all the step that you are talking about.  i m wrong but  you just turn the radio on then the heli. it sould work then right. i think the radio is not working right. thank for your time with this.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Old_Iron_Spine: 308

bvc: 250

Redfive: 221

Freeonthree: 214

MikeK: 172

drewdane: 155

Member Stats:

Guest Posters: 2

Members: 1650

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1262

Posts: 8128

Newest Members:

samanthabaker1202, Projectdiy, ter, gzdenek, cyclib, ron hallam

Administrators: Syma Freak: 1459, Supernova: 771, JamDJ: 258