Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
S107G Stopped Working
Syma S107G doesn't light up anymore or charge up.
Tags: Syma X9
Avatar
Wills41
Guest
Guests
December 27, 2012 - 2:03 am

My son got a new S107G for Christmas. He got it out of the box and plugged it into the controller which had brand new Duracell batteries. He left it for a few hours (!!!) then tried flying it. The heli's lights came on when it was switched on and it responded to the controls. However, it barely left the ground and so after a few minutes he switched it off and plugged it back into the controller. The controller light flashed red then went to flashing green for a few minutes before going off. No lights lit on helicopter. He unplugged the heli after a few more minutes and tried switching on but no lights coming on - seems completely dead. Is there any hope or is it fried?

Avatar
Syma Freak
Admin
December 27, 2012 - 11:56 am
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

Leaving for a few hours charging by the remote could have cooked the battery,however was the remote turned on while charging as required-Try charging with supplied usb cable from your computer-saves the batteries in remote and faster- maybe worth trying some new batteries in remote.Let us know how you go.SF

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
CPD
Guest
Guests
December 28, 2012 - 3:53 am

Yeah, he could have cooked the battery, so take the nose off and look at the battery to see if it's bloated. (trust me, you can tell, even when you don't know what you're looking at--it's just that noticable when they bloat.) Could be the charger didn't charge it, could be a number of things.

 

I'm assuming you bought this fairly recently, and it hasn't been sitting around for a year without charging, so it shouldn't be that the battery went bad while you had it from not charging.

 

 

So the christmas rush begins...

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

Gyrobob: 35

SymaGuru: 32

RobertNH: 15

Airsucker: 13

swordfish010: 8

Member Stats:

Guest Posters: 712

Members: 592

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1269

Posts: 8165

Newest Members:

Ronnielal, VikaDuest, christiin1, bettytu60, AndrewPaw, VanessaGek

Administrators: Syma Freak: 1429, JamDJ: 254