Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
S022
I am having problem with chinook. When I try to power up to lift, sometimes (many times) it does not respond. Batteriy is strong, I checked. Also when I try to bring her down to shot off, it (rotors) keep running for about 5 seconds. Manual is poorly written.
Tags: Syma X9
Avatar
bgeyer
Guest
Guests
December 28, 2013 - 12:35 pm

Anybody know how to correct these problems?

 

Thank you

Avatar
Syma Freak
Admin
December 29, 2013 - 1:23 pm
Member Since: November 26, 2010
Forum Posts: 1430
sp_UserOfflineSmall Offline

crigon_04  Has the remote been dropped? Sounds to me a remote tx fault especially if you turn throttle off and rotors still spinning, are you flying near a digital TV?

"Fly like a butterfly sting like a Syma" http://syma107.com

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
6 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

swordfish010: 8

nope: 5

groggy: 2

cyclib: 2

Member Stats:

Guest Posters: 718

Members: 735

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1270

Posts: 8167

Newest Members:

ritafep, Shwan, rosset11, sophiapd60, rheajt4, Michaelbaf

Administrators: Syma Freak: 1430, JamDJ: 254