Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Rookie with a forward/backwards problem
Little/no forward/backward speed
Tags: Syma X9
Avatar
kchanman
Guest
Guests
April 15, 2015 - 10:47 am

Hello All,

I just bought my first 107 yesterday.  I love it.  I noticed immediately that it was very sluggish to go forward or backwards except in ground effect.  Today the problem has gotten worse.  Full forward might move at a pace of 5 ft per minute.  The tail rotor is spinning.  Does anyone had any advise or do I get what I paid for $25?

Thanks in advance,

Avatar
Redfive
Guest
Guests
April 15, 2015 - 3:33 pm

No they should fly better than that. check that the tail rotor is not rubbing and thus slowing down.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
10 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

Gyrobob: 35

SymaGuru: 32

RobertNH: 15

Airsucker: 13

swordfish010: 8

Member Stats:

Guest Posters: 711

Members: 507

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1269

Posts: 8165

Newest Members:

Aphukeatkat, Briandaunk, NikolaySpirl, Juliusemake, Richardspund, Kostyaunlok

Administrators: Syma Freak: 1429, Supernova: 733, JamDJ: 254