Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
red 107 DOA
Tags: Syma X9
Avatar
seaturtle
Guest
Guests
February 18, 2012 - 1:10 pm

i have have 2 107's that are down for the count.so when i saw reds on amazon for under $20 i decided to grab one up.i was happily suprised when it showed up overnight,even though i did free 2 day shipping.BUT THEN,the heli would not turn on. then, i plugged it in.the props started turning when plugged in.closer inspection showed white tips on the landing gear,a totally different pcb,and one white motor and one green one.back it goes.grrrrr......im really starting to love my 111

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
6 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

cyclib: 2

groggy: 2

Shwan: 1

Member Stats:

Guest Posters: 726

Members: 911

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

Januszek45Swido, Jamaalcag, nikagreimOnge, elmerdf18, Andrewmug, Moncler Jackets

Administrators: Syma Freak: 1432, JamDJ: 255