Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
My first remote helicopter and I need HELP
Helicopter not taking off
Tags: Syma X9
Avatar
aussie_bron
Guest
Guests
September 14, 2012 - 5:09 am

Hello my name is Bronwyn and I am from Australia.

Yesterday I purchased mt first ever remote helicopter..not bad for a 44 year old lady!

After charging as per instruction booklet, I had no problem with the first test flight just taking it easy and getting the feel of hovering and use of the controls.

When I went to have another fly the helicopter is not taking off the ground even though it starts up etc, it just wont hover.

Batteries are fully charged.

My boys did have a try each but they were fighting over it and were pretty rough on the unit.

Please help.......Thank you

Avatar
CPD
Guest
Guests
September 14, 2012 - 7:51 am

Sounds like one of two things to me--

 

1st, look over the heli for broken wiring connections, things on the motherboard that do not look right, etc.

 

2nd is there a green and a red motor, or are they black/white, black/grey, white/white or black/black?

 

Hope this helps for the first step!

Avatar
Ragnyr
Guest
Guests
September 14, 2012 - 11:53 pm

Just thought did you allow the battery to cool after charge, and cool before recharging, I fell into that trap

I give mine about 30 mins to make sure they are cooled right down now.

If you have only had it short time it might be worth trying to complain and return it !Confused

Avatar
Syma Freak
Admin
September 17, 2012 - 10:41 am
Member Since: November 26, 2010
Forum Posts: 1432
sp_UserOfflineSmall Offline

Supernova put a great video on repairing main shaft,this might be your problem..View Here

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
Supernova
Guest
Guests
September 18, 2012 - 2:44 am

Hi Bronwyn is it sorted now ?

Bernie.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
14 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

groggy: 2

Shwan: 1

runawaytrim: 1

Member Stats:

Guest Posters: 727

Members: 1000

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

evelynethomas, KevinHon, susanneke3, Waisher, NejolneJAMB, Milavawrecy

Administrators: Syma Freak: 1432, JamDJ: 255