Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Lower rotor doesn't spin.
Tags: Syma X9
Avatar
harpua
Guest
Guests
April 18, 2012 - 11:11 am

Just bought a new green S107. It flew just fine at first. Had a few minor crashes but nothing serious. Now when I try to lift off, the lower rotor won't start. I held it and slightly shook it with power on and the rotor would kick on. Any suggestions?

Avatar
CPD
Guest
Guests
April 18, 2012 - 11:33 pm

1 check the gears to make sure that they are A not cockeyed and B ligned up height wise.

 

2 check the wiring to make sure there isn't a broken connection that works when you hit it

 

3 the motor might be bad, but that's the last option if you can help it.

 

If you just bought it and it's under the return period, then you can return it if it's a blown motor for a new one. I doubt on a real one that it's the problem, though.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

cyclib: 2

groggy: 2

Shwan: 1

Member Stats:

Guest Posters: 726

Members: 916

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

RobertGlids, DaryaNaKo, NadejdaJogue, Toranja, JulianDreab, Januszek45Swido

Administrators: Syma Freak: 1432, JamDJ: 255