Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Low on power when new
Avatar
steveenduro
Guest
Guests
February 15, 2012 - 3:16 am

Hi.

For Christmas I was bought a heli (not Syma) but had so much fun (til it eventually broke) that I order a Syma S107G from China. I am in the uk. I'm pretty sure it is a Genuine one.

Despite doing all the good practice with the battery, the heli does not have enough power to climb even after full charge. Also the trim is all the way over to the right. I have checked gear alignment and lower/top rotor security and all is fine. I ordered a new battery and fitted it and it is exactly the same, and the old battery showed good voltage. Compared to my other heli, it just seems pretty lifeless.

I'd really appreciate any help.

 

Steve

Avatar
Supernova
Guest
Guests
February 15, 2012 - 3:47 am

Hi Steve and a big welcome to the forum.

 

Have you looked at my videos yet there could be a fix there for you.

 

http://syma107.com/forum/frequ.....ow-to-fix/

Avatar
seaturtle
Guest
Guests
February 15, 2012 - 1:03 pm

i had the same problem.new battery was worse than the one i was replacing..im just sending it back and will try again.the trim issue is probably a symptom of weak battery.

Avatar
Syma Freak
Admin
February 15, 2012 - 4:37 pm
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

seaturtle said:

i had the same problem.new battery was worse than the one i was replacing..im just sending it back and will try again.the trim issue is probably a symptom of weak battery.

Have you considered Dales Battery mod-I bought a lot of so called original batteries from Ebay some time ago not one of them was any good,just would not charge I understand your frustration.

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
seaturtle
Guest
Guests
February 15, 2012 - 4:45 pm

Syma Freak said:

seaturtle said:

i had the same problem.new battery was worse than the one i was replacing..im just sending it back and will try again.the trim issue is probably a symptom of weak battery.

Have you considered Dales Battery mod-I bought a lot of so called original batteries from Ebay some time ago not one of them was any good,just would not charge I understand your frustration.

you think thats the way to go ,then?

Avatar
Syma Freak
Admin
February 15, 2012 - 4:55 pm
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

Do you have a few Syma 107 helis? If so yes try Dales mod on one.If you prefer the genuine battery have bought from Rcfever and Focalprice They are not cheap around $5- $6 for genuine batteries,hence suggested to try Dales Battery mod

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
steveenduro
Guest
Guests
February 16, 2012 - 11:47 pm

Thanks for the replies.

I can't help thinking that the batteries are ok as seem seem to take and hold a charge ok. And the heli will fly for quite some time (albeit only in ground effect). Also, the heli behaves exactly the same with both batteries.

I've decided to buy another heli (from uk supplier this time) and use the old one as spares. It would be nice to get to the bottom of it though!

Avatar
bhinshaw
Guest
Guests
February 17, 2012 - 11:37 am

Same problem. Mine flew fine until I crashed it Fixed it per Bernies top shaft video, now it won't climb and wants to rotate. Any sugestions?

Avatar
Supernova
Guest
Guests
February 18, 2012 - 2:49 am

bhinshaw said:

Same problem. Mine flew fine until I crashed it Fixed it per Bernies top shaft video, now it won't climb and wants to rotate. Any sugestions?

This could be gear slip because when they crash the energy from the motors is transfered to the next weakest bit.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

Airsucker: 13

swordfish010: 8

nope: 5

cyclib: 2

Member Stats:

Guest Posters: 714

Members: 650

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1269

Posts: 8165

Newest Members:

Frgeti44, Adelacix, AnnieVoW, lilianany60, SantoCeamb, annmariebq18

Administrators: Syma Freak: 1429, JamDJ: 254