Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Issue with S107G
Tags: Syma X9
Avatar
Micah
New Member
Members
May 4, 2015 - 9:42 am
Member Since: May 4, 2015
Forum Posts: 1
sp_UserOfflineSmall Offline

I am having an issue with my S107G it is a couple of years old, but was only flown a few times, but the last time I tried to fly it the propellers would spin, but the helicopter would not take off and then randomly the green LED on the helicopter would start flashing and the propellers would stop. At this time the helicopter would not respond to any of the controls I tried unless I shut off both the controller and the helicopter.

I have tried a few things to attempt to fix the problem, but they haven't really worked. The first thing I tried to do was correct the slippage on the top rotor since this was suggested as being a known issue. In regard to the loss of signal between the controller and helicopter, I tried to replace the batteries in the controller and charge the helicopter, but the same thing happened.

Does anyone know what the issue is and how I can fix it?

Avatar
Redfive
Hampshire England
Member
Members
May 4, 2015 - 7:42 pm
Member Since: January 11, 2015
Forum Posts: 221
sp_UserOfflineSmall Offline

Your helicopter battery may not be holding enough charge. There is a quick solution buy another one and use old one for spares or you can buy a replacement battery and solder it in.

Bryan

Avatar
JamDJ
Lancaster, PA, USA
Admin
May 6, 2015 - 3:22 pm
Member Since: February 14, 2012
Forum Posts: 258
sp_UserOfflineSmall Offline

Micah, first of all, welcome to the forum! Please post and check back often!

I'm going to reinforce what Redfive replied. I agree that the problem is in your

S107s battery. You stated that yours is a couple of years old and only flown a few times.

They do need to be charged and discharged regulary, once the initial charge is 

applied. Otherwise, the battery will go dormant, as we say "crystalised" and won't

hold a full charge. Therefore, it will hold enough power to spin the blades but not enough

for lift-off. Also, the heli won't receive the signal correctly from your remote, thus the flashing

green LED you stated.

  Best bet would be to buy another battery for the heli, they are a dime-a-dozen on Amazon,

or like Bryan said, just get a new one and keep your current one for parts. The new S107s

have cooler-looking paint schemes, and disreguard the "G" not being at the end of the model

number. "G" stands for "gyroscope" and is now a standard feature, therefore, Syma doesn't

use that nomenclature anymore!

  Again, welcome to our forum and please check back and post often!

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Old_Iron_Spine: 308

bvc: 250

Redfive: 221

Freeonthree: 214

MikeK: 172

drewdane: 155

Member Stats:

Guest Posters: 2

Members: 1650

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1262

Posts: 8128

Newest Members:

samanthabaker1202, Projectdiy, ter, gzdenek, cyclib, ron hallam

Administrators: Syma Freak: 1459, Supernova: 771, JamDJ: 258