Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
I installed bigger batterie now rear rotor doesn't work?
Tags: Syma X9
Avatar
roger
Guest
Guests
March 10, 2012 - 4:14 pm

I installed bigger batterie now rear rotor doesn't work? does this make sense? What happened?

Avatar
CPD
Guest
Guests
March 12, 2012 - 1:46 am

Probably knocked a wire loose somewhere when you had the board out for soldering. Just look it over, and see.

 

As for the larger batery, what size did you put in? From what I've read from some tests one guy (wherever he whent) put on one topic, about 240-250 mah works best-any larger and you have either not enough lift to get it off of the ground, or it has to use all of the power to lift it. Less, and you have a lot less power from the batery.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
6 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

cyclib: 2

groggy: 2

Shwan: 1

Member Stats:

Guest Posters: 726

Members: 911

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

Januszek45Swido, Jamaalcag, nikagreimOnge, elmerdf18, Andrewmug, Moncler Jackets

Administrators: Syma Freak: 1432, JamDJ: 255