Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Does Not Fly Well
Tags: Syma X9
Avatar
SkinnyHippo
Guest
Guests
January 3, 2012 - 10:14 am

Out of the box it does not fly well. Would return it but someone got rid of the box. It seems as if the top blade is hitting the balance bar or the bottom blade. Any help on what to do?

Avatar
CPD
Guest
Guests
January 3, 2012 - 11:26 am

Is everything tight and the dogbones between the top and the blades connecting?

 

After checking that, look over the "blades hitting" topic- I think there's some stuff you might want to know there before you reach the point where we got that problem solved and were sidetracked with cool moves they did in WWI triplanes. Lol.

 

Anyway, this is a fluke that we've been seeing here a lot recently. They make bad batches, and then we get swamped with the same problem for quite a while. Right now, it seems to be the top peice of the main shaft and some batteries are DOA. (reminds me- there's a special announcement from the Battery Protection Board-- keep that battery topped off every few weeks until you want to have to buy a new battery!!!)

Avatar
SkinnyHippo
Guest
Guests
January 3, 2012 - 12:19 pm

I saw that thread after and I do believe I have the same problem. As the top blades hang down way to much and collide with the bottom. I'm really not that very crafty so I think I might just get a new part.

Avatar
CPD
Guest
Guests
January 3, 2012 - 12:36 pm

Great to see you found the problem!

 

They don't sell just that part for some reason- you need to buy and replace the whole shaft.

 

I don't know why those connections are breaking, but that seems to be from just one batch. Order the $4 blades too. There's one where you get something rediculous like 8 sets or something for $4, so buy them- you'll need em'!

Avatar
SkinnyHippo
Guest
Guests
January 3, 2012 - 1:04 pm

Yea thanks for the help. I just can't wait to really fly this baby. lol I never had anything like this but always wanted to try them and my girlfriend got me this for christmas.

Avatar
bvc
Guest
Guests
January 3, 2012 - 1:46 pm

CPD said:

Great to see you found the problem!

 

They don't sell just that part for some reason- you need to buy and replace the whole shaft.

 

I don't know why those connections are breaking, but that seems to be from just one batch. Order the $4 blades too. There's one where you get something rediculous like 8 sets or something for $4, so buy them- you'll need em'!

Why the whole shaft? The top just screws on.

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

SymaGuru: 32

nope: 5

groggy: 2

cyclib: 2

Shwan: 1

Member Stats:

Guest Posters: 722

Members: 800

Moderators: 0

Admins: 2

Forum Stats:

Groups: 7

Forums: 15

Topics: 1272

Posts: 8171

Newest Members:

petr-osipovbm, wapedged, BillyBoabe, gbalychik, Abnerhawrecy, anthonyfg4

Administrators: Syma Freak: 1432, JamDJ: 255