Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
DOA S107. Before I send back, any ideas on what to try?
Avatar
my2m8ogt
Member
Members
December 26, 2011 - 4:16 am
Member Since: December 26, 2011
Forum Posts: 3
sp_UserOfflineSmall Offline

Santa brought me the Phantom S107 from World Tech Toys (looks like the Syma).  I plug in the USB charger, Light in USB plug glows bright after some time (this is supposed to mean it is charged).  I unplug choppet from charging. I turn on chopper and wait till green light stops flashng and see that the LED is flashing red and blue.  OK so far looks good. I turn on the remote, it flashes green once then burns steady. then NOTHING.  Chopper just sits there, flashing and looking cool.  I also tried charging from the remote.. Still nothing.

Anything I should try before sending it back??

Thanks, Cliff

Avatar
CPD
PA
Member
December 26, 2011 - 4:53 am
Member Since: November 18, 2011
Forum Posts: 1093
sp_UserOfflineSmall Offline

Not the heli- it's the remote, I think.

 

Try syncing it up by going full up twice, then a third time to get it rolling. I bought the same one, and I had issues with it not wanting to take off at first too.

 

You also have to toy with turning the heli on before after the remote- for some reason they don't like to fly unless you play with getting them on before or after the remote, but I don't remember which. (my phantom's tore down for a project I've been working on)

 

I think the combo of on before or on after is what's the issue- they're really pickey about that...

Avatar
my2m8ogt
Member
Members
December 26, 2011 - 7:11 am
Member Since: December 26, 2011
Forum Posts: 3
sp_UserOfflineSmall Offline

USB plug glowing bright.

Unplugged Charger from chopper.

Chopper turned on, then remote turned on with switch on remote set to "A" position. Nothing.

Repeated this for position "B" and "C". Nothing.

On to reversing the order.

Remote turned on (pos "A"), then power up Chopper.

Repeated with remote at Pos "B" and "C" then chopper on.

Non of this worked. Chopper sat there with LEDs flashing but NO blades spinning.

I will try again later, but for now it stays DEAD. 

Thanks...

Avatar
AshtonFlyer
UK
Member
Members
December 26, 2011 - 8:04 am
Member Since: December 25, 2011
Forum Posts: 5
sp_UserOfflineSmall Offline

pop the front off the remote (only about 5 screws - one's hidden in the charger panel - you'll need to force the panel off completely to reach it)

 

 Check all the wiring is solid inside. I had to reseat a connector on the main board to get mine working.

Avatar
CPD
PA
Member
December 27, 2011 - 6:04 am
Member Since: November 18, 2011
Forum Posts: 1093
sp_UserOfflineSmall Offline

I still say it's needing to turn off the heli, try again. Turn off the remote, try again. You have to go power full up twice, also- not just power up.

 

Next, check the angle of the reciever to make sure it's not being blocked by the stabilizer bars (the diagonal ones) or the frame.

 

Then, crack open the remote as suggested, and look for loose wires or missing parts. (and etc)

 

If it doesn't work, buy annother at aldi's, try both with the new remote- one in A, one in B- and see if you can get them to work. If it still doesn't work, take it back and keep the other. If it does work, don't take them, back, cause you'll end up just going out to buy annother later on anyway.

 

My phantom takes easilly 3-4 tries sometime to get going, and I constantly have to swap on/off on the remote and the heli. Keep trying...

Avatar
my2m8ogt
Member
Members
December 27, 2011 - 6:40 am
Member Since: December 26, 2011
Forum Posts: 3
sp_UserOfflineSmall Offline

What ever happened to when you buy something and turn both on they work?  All my other RC's work right away after both are powered up.

Just want to rule out something here. Being as there are NO user manual that gets into more detail. Anyone know what the A B C switch is for?  I assume it is for channel select so more then one chopper can fly at a time.  This adds to the power up, one before the other. Many combinations to try being as I do not know which channel the chopper uses.  What a pain.

Thanks for everyones' help, Cliff

Avatar
Wingnut79
Greenville TX
Member
Members
December 27, 2011 - 7:01 am
Member Since: December 16, 2011
Forum Posts: 43
sp_UserOfflineSmall Offline

the "ABC" select switch is for the "channel" select. I've read somewhere that one of the channels is a "dummy" channel and in reality there's only two working channels, even with the ones that have a three channel switch. 

Avatar
Syma Freak
Admin
December 27, 2011 - 2:06 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Correct most have either B-C The other does not move-yes they call it a 3 channel heli witch it is,but not best explained only two channels work on remote but give you 3 channels on heli

"Fly like a butterfly sting like a Syma" http://syma107.com

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Old_Iron_Spine: 308

bvc: 250

Redfive: 221

Freeonthree: 214

MikeK: 172

drewdane: 155

Member Stats:

Guest Posters: 2

Members: 1650

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1262

Posts: 8128

Newest Members:

samanthabaker1202, Projectdiy, ter, gzdenek, cyclib, ron hallam

Administrators: Syma Freak: 1459, Supernova: 771, JamDJ: 258