Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
Bottom blades do not rotate!
Avatar
SPANK DAT SYMA
New Member
Members
October 27, 2011 - 5:09 am
Member Since: October 27, 2011
Forum Posts: 1
sp_UserOfflineSmall Offline

Hi, yall, I'm new here, and to the helic-hobbying in general. I sure do like my syma s107 though.

 

Hope my question is not retarded but the bottom/lower blade does not spin, what could be the problem and how can I fix it?

 

cheers in advance!

Avatar
Syma Freak
Admin
October 28, 2011 - 12:01 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Guess you have tightened blades?is the blades slipping on main shaft-have you checked gears are meshing ok-keep us posted

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
mcruss
Texas
Member
Members
October 30, 2011 - 2:01 pm
Member Since: October 30, 2011
Forum Posts: 3
sp_UserOfflineSmall Offline

I have similar problem with one of my birds but it is the top blades that do not rotate.  I've traced the problem to the motor (try turning the blades by hand and you can feel the resistance in the motor IF it is working....mine just spins freely.)  Happened after I installed a new battery (stock), not sure why.

Avatar
Syma Freak
Admin
October 31, 2011 - 2:55 pm
Member Since: November 26, 2010
Forum Posts: 1459
sp_UserOfflineSmall Offline

Tony put a great comment on main page

"Check the 2 small screws at the head (top rotor blades) and be sure they are tight and the screw on one side is against the flat part on the inner shaft. Also make sure there is NO (or very little, very tiny) bit of slop in up and down movement of the inner shaft. This is a common thing in most cases. The upper blades are turning, but not fast enough. They are most likely spinning on the shaft. The 2 screws are located on each side just below the fly bar. One tightens against the flat spot on shaft the other simply against the shaft. You’have to loosen them a bit and pull the upper part off to line up and insure screw alignment with flat spot on shaft. Pretty easy actually. I “believe” this will cure your problem."

"Fly like a butterfly sting like a Syma" http://syma107.com

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Old_Iron_Spine: 308

bvc: 250

Redfive: 221

Freeonthree: 214

MikeK: 172

drewdane: 155

Member Stats:

Guest Posters: 2

Members: 1650

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1262

Posts: 8128

Newest Members:

samanthabaker1202, Projectdiy, ter, gzdenek, cyclib, ron hallam

Administrators: Syma Freak: 1459, Supernova: 771, JamDJ: 258