Welcome to our Syma Forum - Please click on topics to view comments.You have to be a member to post-Free to join. Enter correct email as password will be emailed to you- All Syma Helicopter help and advice here. NEW- you can now change color of forum, bottom of page!

A A A
Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_Related Related Topics sp_TopicIcon
107 Woe's
after l replace new blades on s107, it doesn't take off. It starts fine but when l throttle up, it seems the blades trip over each other, then it careers off across the floor, in any direction but up.
Tags: Syma X9
Avatar
Nosrettap
Guest
Guests
December 30, 2013 - 7:26 am

after l replace new blades on s107, it doesn't take off. It starts fine but when l throttle up, it seems the blades trip over each other, then it careers off across the floor, in any direction but up.

i checked l put the blades on correctly,which they where & after l checked the rest of heli' over for any other faults. there was none......& so l challenge anyone to help me please.

just had a thought, could it be a damaged/bent rear rotor boom arm,thingy.

l dont have another 107 to cannibalise, so l cant diagnose the problem....or could this give me an excuse to purchase another. 

 

 

Avatar
Syma Freak
Admin
December 30, 2013 - 4:41 pm
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

As myself and CPD said the batteries you might be buying from Ebay or else where are old and will not hold a charge, get yourself a cheap meter to check this here

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
CPD
Guest
Guests
January 2, 2014 - 9:58 am

I'm thinking that it's probably an issue with the blades, and not the battery. From what it sounds like, either the blades you have are a slightly different version, or there's a balance bar issue. They've had a few gens of Syma blades, with long 107 blades, military blades, their current ones, and one kind I bought off of Amazon that is VERY unstable on helis not made for them. Check that the old ones and the new ones are the same size/shape, and if they're not, "well there's yer prahblem."

Also, check that you didn't knock off the dogbones on the balance bar. That'll do the same thing.

Avatar
Syma Freak
Admin
January 5, 2014 - 8:08 pm
Member Since: November 26, 2010
Forum Posts: 1429
sp_UserOfflineSmall Offline

I think CPD is correct with your problem, dogbones!

"Fly like a butterfly sting like a Syma" http://syma107.com

Avatar
lew803
Guest
Guests
March 6, 2014 - 4:06 am

Hey Nosrettap,Don't see a reply about the blade problem.Did you solve the problem?sco_huhsign

Forum Timezone: Australia/Sydney

Most Users Ever Online: 84

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

MikeK: 178

Gyrobob: 35

SymaGuru: 32

RobertNH: 15

Airsucker: 13

swordfish010: 8

Member Stats:

Guest Posters: 711

Members: 510

Moderators: 0

Admins: 3

Forum Stats:

Groups: 7

Forums: 15

Topics: 1269

Posts: 8165

Newest Members:

harrietkt16, joycedl3, IsmaelJax, Aphukeatkat, Briandaunk, NikolaySpirl

Administrators: Syma Freak: 1429, Supernova: 733, JamDJ: 254